2576d9ffc4
* gnu/packages/patches/python-ipython-documentation-chars.patch: New file. * gnu/packages/patches/python-ipython-documentation-repro.patch: Likewise. * gnu/local.mk: Register them. * gnu/packages/python-xyz.scm (python-ipython-documentation) [source]: Apply patches. [arguments]: Use gexps. [phases]{sanitize-sources}: New phase. {configure-sphinx-for-xelatex}: Likewise. {install}: Streamline. Also build and install the PDF and info manual. Enable parallel processing. [inputs]: Delete field. [propagated-inputs]: Remove texlive-updmap.cfg input. Add fontconfig, font-gnu-freefont, graphviz, python-docrepr, texlive-polyglossia, texlive-bin and texlive-xindy.
18 lines
863 B
Diff
18 lines
863 B
Diff
Avoid LaTeX errors due to non-printable characters.
|
|
Submitted upstream: https://github.com/ipython/ipython/pull/13640
|
|
|
|
diff --git a/IPython/utils/coloransi.py b/IPython/utils/coloransi.py
|
|
index e33142180..9300b0108 100644
|
|
--- a/IPython/utils/coloransi.py
|
|
+++ b/IPython/utils/coloransi.py
|
|
@@ -74,8 +74,8 @@ class TermColors:
|
|
class InputTermColors:
|
|
"""Color escape sequences for input prompts.
|
|
|
|
- This class is similar to TermColors, but the escapes are wrapped in \001
|
|
- and \002 so that readline can properly know the length of each line and
|
|
+ This class is similar to TermColors, but the escapes are wrapped in \\001
|
|
+ and \\002 so that readline can properly know the length of each line and
|
|
can wrap lines accordingly. Use this class for any colored text which
|
|
needs to be used in input prompts, such as in calls to raw_input().
|
|
|