40d5931a60
* gnu/packages/patches/libsigrokdecode-python3.9-fix.patch: New file. * gnu/local.mk (dist_patch_DATA): Adjust accordingly. * gnu/packages/electronics.scm (libsigrokdecode)[native-inputs]: Add automake, autoconf. [source](patches): New field.
19 lines
1.1 KiB
Diff
19 lines
1.1 KiB
Diff
From: Dan Horák <dan@danny.cz>
|
|
Subject: Add support for Python 3.9
|
|
|
|
Origin: upstream, https://sigrok.org/gitweb/?p=libsigrokdecode.git;a=commitdiff;h=9b0ad5177bd692f7556a4756bdbd2da81d9c34ce
|
|
Bug-Debian: https://bugs.debian.org/972769
|
|
|
|
diff --git a/configure.ac b/configure.ac
|
|
index f9958b3..2917cb3 100644
|
|
--- a/configure.ac
|
|
+++ b/configure.ac
|
|
@@ -100,7 +100,7 @@ SR_PKG_CHECK_SUMMARY([srd_pkglibs_summary])
|
|
# first, since usually only that variant will add "-lpython3.8".
|
|
# https://docs.python.org/3/whatsnew/3.8.html#debug-build-uses-the-same-abi-as-release-build
|
|
SR_PKG_CHECK([python3], [SRD_PKGLIBS],
|
|
- [python-3.8-embed], [python-3.8 >= 3.8], [python-3.7 >= 3.7], [python-3.6 >= 3.6], [python-3.5 >= 3.5], [python-3.4 >= 3.4], [python-3.3 >= 3.3], [python-3.2 >= 3.2], [python3 >= 3.2])
|
|
+ [python-3.9-embed], [python-3.8-embed], [python-3.8 >= 3.8], [python-3.7 >= 3.7], [python-3.6 >= 3.6], [python-3.5 >= 3.5], [python-3.4 >= 3.4], [python-3.3 >= 3.3], [python-3.2 >= 3.2], [python3 >= 3.2])
|
|
AS_IF([test "x$sr_have_python3" = xno],
|
|
[AC_MSG_ERROR([Cannot find Python 3 development headers.])])
|
|
|