887dec8a51
* gnu/packages/patches/itk-snap-alt-glibc-compat.patch: New patch. * gnu/local.mk (dist_patch_DATA): Register it. * gnu/packages/image-processing.scm (itk-snap): Apply it. [phases]: Delete trailing #t. [inputs]: Use new style. Replace vtk-6 with vtk-7.
22 lines
753 B
Diff
22 lines
753 B
Diff
Retrieved from ALT Linux.
|
|
https://git.altlinux.org/tasks/273587/build/300/x86_64/srpm/itk-snap-3.8.0-alt6.src.rpm
|
|
|
|
diff --git a/GUI/Qt/main.cxx b/GUI/Qt/main.cxx
|
|
index 576f7160..ceab92e6 100644
|
|
--- a/GUI/Qt/main.cxx
|
|
+++ b/GUI/Qt/main.cxx
|
|
@@ -51,12 +51,13 @@ using namespace std;
|
|
#if defined (__unix__) || (defined (__APPLE__) && defined (__MACH__))
|
|
|
|
#include <signal.h>
|
|
+#include <string.h>
|
|
#include <execinfo.h>
|
|
|
|
void SegmentationFaultHandler(int sig)
|
|
{
|
|
cerr << "*************************************" << endl;
|
|
- cerr << "ITK-SNAP: " << sys_siglist[sig] << endl;
|
|
+ cerr << "ITK-SNAP: " << strsignal(sig) << " (" << sigabbrev_np(sig) << ")" << endl;
|
|
cerr << "BACKTRACE: " << endl;
|
|
void *array[50];
|
|
int nsize = backtrace(array, 50);
|