52d945d382
* gnu/packages/patches/fifengine-boost-compat.patch: New file. * gnu/local.mk (dist_patch_DATA): Adjust accordingly. * gnu/packages/games.scm (fifengine)[source](patches): Add it. [arguments]: Remove defunct Python module import.
17 lines
478 B
Diff
17 lines
478 B
Diff
Fix build with newer Boost.
|
|
|
|
Taken from upstream:
|
|
|
|
https://github.com/fifengine/fifengine/commit/8072f18a9bf4e75c3e1b197b6ccda11e82954460
|
|
|
|
diff --git a/engine/core/vfs/zip/zipnode.cpp b/engine/core/vfs/zip/zipnode.cpp
|
|
--- a/engine/core/vfs/zip/zipnode.cpp
|
|
+++ b/engine/core/vfs/zip/zipnode.cpp
|
|
@@ -28,6 +28,7 @@
|
|
#include "vfs/fife_boost_filesystem.h"
|
|
|
|
#include "zipnode.h"
|
|
+#include <algorithm>
|
|
|
|
namespace {
|
|
/** helper function to find a value in a ZipNodeContainer
|