e76cbdcd90
* gnu/packages/patches/beets-werkzeug-compat.patch: New file. * gnu/local.mk (dist_patch_DATA): Adjust accordingly. * gnu/packages/music.scm (beets)[source](patches): New field.
18 lines
535 B
Diff
18 lines
535 B
Diff
Be compatible with python-werkzeug 1.0.0.
|
|
|
|
Taken from upstream:
|
|
https://github.com/beetbox/beets/commit/d43d54e21cde97f57f19486925ab56b419254cc8
|
|
|
|
diff --git a/beetsplug/web/__init__.py b/beetsplug/web/__init__.py
|
|
index f53fb3a954..21ff5d94ed 100644
|
|
--- a/beetsplug/web/__init__.py
|
|
+++ b/beetsplug/web/__init__.py
|
|
@@ -169,7 +169,7 @@ def to_python(self, value):
|
|
return ids
|
|
|
|
def to_url(self, value):
|
|
- return ','.join(value)
|
|
+ return ','.join(str(v) for v in value)
|
|
|
|
|
|
class QueryConverter(PathConverter):
|