d58e2f2723
* gnu/packages/patches/libblockdev-glib-compat.patch: New file. * gnu/local.mk (dist_patch_DATA): Adjust accordingly. * gnu/packages/disk.scm (libblockdev)[source](patches): New field.
61 lines
2.2 KiB
Diff
61 lines
2.2 KiB
Diff
Don't use g_memdup() which is removed in newer versions of GLib.
|
|
|
|
See <https://github.com/storaged-project/libblockdev/pull/623>.
|
|
|
|
Taken from upstream:
|
|
https://github.com/storaged-project/libblockdev/commit/5528baef6ccc835a06c45f9db34a2c9c3f2dd940
|
|
|
|
diff --git a/src/lib/plugin_apis/vdo.api b/src/lib/plugin_apis/vdo.api
|
|
--- a/src/lib/plugin_apis/vdo.api
|
|
+++ b/src/lib/plugin_apis/vdo.api
|
|
@@ -170,7 +170,22 @@ void bd_vdo_stats_free (BDVDOStats *stats) {
|
|
* Deprecated: 2.24: Use LVM-VDO integration instead.
|
|
*/
|
|
BDVDOStats* bd_vdo_stats_copy (BDVDOStats *stats) {
|
|
- return g_memdup (stats, sizeof (BDVDOStats));
|
|
+ if (stats == NULL)
|
|
+ return NULL;
|
|
+
|
|
+ BDVDOStats *new_stats = g_new0 (BDVDOStats, 1);
|
|
+
|
|
+ new_stats->block_size = stats->block_size;
|
|
+ new_stats->logical_block_size = stats->logical_block_size;
|
|
+ new_stats->physical_blocks = stats->physical_blocks;
|
|
+ new_stats->data_blocks_used = stats->data_blocks_used;
|
|
+ new_stats->overhead_blocks_used = stats->overhead_blocks_used;
|
|
+ new_stats->logical_blocks_used = stats->logical_blocks_used;
|
|
+ new_stats->used_percent = stats->used_percent;
|
|
+ new_stats->saving_percent = stats->saving_percent;
|
|
+ new_stats->write_amplification_ratio = stats->write_amplification_ratio;
|
|
+
|
|
+ return new_stats;
|
|
}
|
|
|
|
GType bd_vdo_stats_get_type () {
|
|
diff --git a/src/plugins/vdo.c b/src/plugins/vdo.c
|
|
--- a/src/plugins/vdo.c
|
|
+++ b/src/plugins/vdo.c
|
|
@@ -81,7 +81,22 @@ void bd_vdo_stats_free (BDVDOStats *stats) {
|
|
}
|
|
|
|
BDVDOStats* bd_vdo_stats_copy (BDVDOStats *stats) {
|
|
- return g_memdup (stats, sizeof (BDVDOStats));
|
|
+ if (stats == NULL)
|
|
+ return NULL;
|
|
+
|
|
+ BDVDOStats *new_stats = g_new0 (BDVDOStats, 1);
|
|
+
|
|
+ new_stats->block_size = stats->block_size;
|
|
+ new_stats->logical_block_size = stats->logical_block_size;
|
|
+ new_stats->physical_blocks = stats->physical_blocks;
|
|
+ new_stats->data_blocks_used = stats->data_blocks_used;
|
|
+ new_stats->overhead_blocks_used = stats->overhead_blocks_used;
|
|
+ new_stats->logical_blocks_used = stats->logical_blocks_used;
|
|
+ new_stats->used_percent = stats->used_percent;
|
|
+ new_stats->saving_percent = stats->saving_percent;
|
|
+ new_stats->write_amplification_ratio = stats->write_amplification_ratio;
|
|
+
|
|
+ return new_stats;
|
|
}
|
|
|
|
|