64e78659f4
* gnu/packages/games.scm (irrlicht): Update to 1.8.5. [source]: Use unmodified Debian patches rather than manually maintain a custom mash-up. [arguments]: Add a new 'delete-broken-install-rule phase instead. Don't explicitly return #t from phases. * gnu/packages/patches/irrlicht-link-against-needed-libs.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it.
24 lines
863 B
Diff
24 lines
863 B
Diff
From: Christoph Egger <Christoph.Egger@gmx.de>
|
|
Subject: [PATCH] debian/link-against-needed-libs
|
|
|
|
There are quite some libraries irrlicht needs but does not link
|
|
against. This patch makes irrlicht link correctly against all the
|
|
needed libraries.
|
|
|
|
Signed-off-by: Christoph Egger <Christoph.Egger@gmx.de>
|
|
|
|
---
|
|
source/Irrlicht/Makefile | 2 +-
|
|
1 files changed, 1 insertions(+), 1 deletions(-)
|
|
|
|
--- irrlicht.orig/source/Irrlicht/Makefile
|
|
+++ irrlicht/source/Irrlicht/Makefile
|
|
@@ -90,7 +90,7 @@
|
|
LIB_PATH = ../../lib/$(SYSTEM)
|
|
INSTALL_DIR = /usr/local/lib
|
|
sharedlib install: SHARED_LIB = libIrrlicht.so
|
|
-sharedlib: LDFLAGS += -L/usr/X11R6/lib$(LIBSELECT) -lGL -lXxf86vm
|
|
+staticlib sharedlib: LDFLAGS += -L/usr/X11R6/lib$(LIBSELECT) -lGL -lXxf86vm -lX11 -lz -lpng -ljpeg -lbz2
|
|
staticlib sharedlib: CXXINCS += -I/usr/X11R6/include
|
|
|
|
#OSX specific options
|