guix/gnu/packages/patches/zig-do-not-link-against-librt.patch
Josselin Poiret 228c9308ff
gnu: zig: Fix build.
* gnu/packages/patches/zig-do-not-link-against-librt.patch: New file.
* gnu/local.mk (dist_patch_DATA): Register it.
* gnu/packages/zig.scm (zig-0.10): Use it.  Also force LLVM to be dynamically
linked, and set up the CC env variable.
(zig-0.9): Also use the above patch.

Signed-off-by: Andreas Enge <andreas@enge.fr>
2023-04-22 13:50:20 +02:00

11 lines
293 B
Diff

--- a/src/target.zig 2023-04-22 11:44:47.917416658 +0200
+++ b/src/target.zig 2023-04-22 11:45:04.577465352 +0200
@@ -478,7 +478,6 @@
"-lpthread",
"-lc",
"-ldl",
- "-lrt",
"-lutil",
},
},