guix/gnu/packages/patches/vtk-7-gcc-11-compat.patch
宋文武 1dc8cdaa72
gnu: vtk-7: Fix build.
* gnu/packages/patches/vtk-7-gcc-11-compat.patch: New file.
* gnu/local.mk (dist_patch_DATA): Register it.
* gnu/packages/image-processing.scm (vtk-7)[source]: Add patch for gcc-11.
2023-08-31 18:01:52 +08:00

12 lines
544 B
Diff

Description: GCC 11 now enforces that comparison objects be invocable as const.
--- a/Rendering/Label/vtkLabelHierarchy.cxx
+++ b/Rendering/Label/vtkLabelHierarchy.cxx
@@ -525,1 +525,1 @@
- const vtkHierarchyNode & b)
+ const vtkHierarchyNode & b) const
--- a/Rendering/Label/vtkLabelHierarchyPrivate.h
+++ b/Rendering/Label/vtkLabelHierarchyPrivate.h
@@ -66,1 +66,1 @@
- bool operator () ( const vtkIdType& a, const vtkIdType& b )
+ bool operator () ( const vtkIdType& a, const vtkIdType& b ) const