guix/gnu/packages/patches/qtbase-moc-ignore-gcc-macro.patch
Marius Bakke 26e92a3025
gnu: qtbase: Patch the 'moc' executable to cope with GCCs C++ headers.
* gnu/packages/patches/qtbase-moc-ignore-gcc-macro.patch: New file.
* gnu/local.mk (dist_patch_DATA): Adjust accordingly.
* gnu/packages/qt.scm (qtbase)[source](patches): Add it.
2020-03-29 11:35:04 +02:00

18 lines
759 B
Diff

The moc executable loops through headers on CPLUS_INCLUDE_PATH and stumbles
on the GCC internal _GLIBCXX_VISIBILITY macro. Tell it to ignore it as it is
not supposed to be looking there to begin with.
Upstream report: https://bugreports.qt.io/browse/QTBUG-83160
diff --git a/src/tools/moc/main.cpp b/src/tools/moc/main.cpp
--- a/src/tools/moc/main.cpp
+++ b/src/tools/moc/main.cpp
@@ -188,6 +188,7 @@ int runMoc(int argc, char **argv)
dummyVariadicFunctionMacro.arguments += Symbol(0, PP_IDENTIFIER, "__VA_ARGS__");
pp.macros["__attribute__"] = dummyVariadicFunctionMacro;
pp.macros["__declspec"] = dummyVariadicFunctionMacro;
+ pp.macros["_GLIBCXX_VISIBILITY"] = dummyVariadicFunctionMacro;
QString filename;
QString output;