guix/gnu/packages/patches/python-uqbar-python3.10.patch
Troy Figiel 51d25c771c
gnu: python-uqbar: Update to 0.5.9.
* gnu/packages/graphviz.scm (python-uqbar): Update to 0.5.9.
[source]: Add patch for Python 3.10 compatibility.
[arguments]: Remove outdated patch phase.

Change-Id: I81d83efd69bd07fe12790981c48a6e82297908f0
Signed-off-by: Ludovic Courtès <ludo@gnu.org>
2024-01-07 16:56:00 +01:00

24 lines
796 B
Diff

Since Python 3.10 the output of a CLI program created with argparse
uses "options" instead of "optional arguments". This behaviour breaks
the tests in python-uqbar.
--- a/tests/test_cli.py
+++ b/tests/test_cli.py
@@ -84,7 +84,7 @@ def test_call_help():
speak like a cat
- optional arguments:
+ options:
-h, --help show this help message and exit
--version show program's version number and exit
--loud be adamant
@@ -101,6 +101,6 @@ def test_help():
"""
usage: vox-aggregator [-h] [--version] {help,list,birds,mammals} ...
- optional arguments:
+ options:
-h, --help show this help message and exit
--version show program's version number and exit