guix/gnu/packages/patches/python-docrepr-fix-tests.patch
Greg Hogan 53c47c4f28
gnu: python-docrepr: Fix tests.
* gnu/packages/patches/python-docrepr-fix-tests.patch: New file.
* gnu/local.mk (dist_patch_DATA): Register it here.
* gnu/packages/documentation.scm (python-docrepr)[source]<patches>: Use
  it here.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
2023-06-02 16:08:28 +02:00

17 lines
527 B
Diff

Fixes the errors with use of asyncio in docrepr/tests/test_output.py:
> await compare_screenshots(test_id, url)
E TypeError: 'coroutine' object is not callable
--- a/conftest.py
+++ b/conftest.py
@@ -65,7 +65,7 @@ def _open_browser(url):
@pytest.fixture
-async def compare_screenshots(request):
+def compare_screenshots(request):
"""Run visual regression test on the output."""
async def _compare_screenshots(test_id, url):
if (request.config.getoption(COMPARE_SCREENSHOTS_OPTION) or