guix/gnu/packages/patches/open-zwave-hidapi.patch
Ludovic Courtès 123b9c02dd
gnu: open-zwave: Unbundle hidapi.
* gnu/packages/patches/open-zwave-hidapi.patch: New file.
* gnu/local.mk (dist_patch_DATA): Add it.
* gnu/packages/zwave.scm (open-zwave)[source](patches): New field.
(snippet): Delete 'cpp/hidapi'.
[native-inputs]: Add PKG-CONFIG.
[inputs]: Add HIDAPI.
2019-06-17 12:36:13 +02:00

16 lines
561 B
Diff

Build against the system's HIDAPI instead of the bundled one.
--- open-zwave-1.6-checkout/cpp/build/support.mk 2019-06-16 15:15:34.258331628 +0200
+++ open-zwave-1.6-checkout/cpp/build/support.mk 2019-06-16 15:15:54.698249462 +0200
@@ -86,6 +86,10 @@ endif
endif
SED := sed
+# Build against the system's HIDAPI.
+CPPFLAGS += $(shell pkg-config hidapi-libusb --cflags)
+LDFLAGS += $(shell pkg-config hidapi-libusb --libs)
+
#determine if we are release or debug Build and set appropriate flags
ifeq ($(BUILD), release)
CFLAGS += -c $(RELEASE_CFLAGS)