guix/gnu/packages/patches/maturin-no-cross-compile.patch
Efraim Flashner 04b2a8d2a7
gnu: maturin: Update to 1.4.0.
* gnu/packages/rust-apps.scm (maturin): Update to 1.4.0.
[source]: Add snippet to fix compilation.
[cargo-inputs]: Add rust-path-slash-0.2.  Replace rust-cargo-options-0.6
with 0.7, rust-cargo-metadata-0.16 with 0.18, rust-cbindgen-0.24 with
0.26, rust-dialoguer-0.10 with 0.11, rust-goblin-0.6 with 0.7,
rust-indexmap-1 with 2, rust-itertools-0.10 with 0.12,
rust-minijinja-0.34 with 1, rust-pyproject-toml-0.6 with 0.8,
rust-python-pkginfo-0.5 with 0.6, rust-rustls-0.20 with 0.21,
rust-rustls-pemfile-1 with 2, rust-toml-0.7 with 0.8,
rust-toml-edit-0.19 with 0.21.
Remove rust-same-file-1.
[cargo-development-inputs]: Add rust-expect-test-1.  Replace
rust-which-4 with 5.
* gnu/packages/patches/maturin-no-cross-compile.patch: Refresh patch.

Change-Id: I1c943ad1a9a3cb315e5baa287f7ba5bc7bc15413
2024-02-20 13:56:39 +02:00

56 lines
1.2 KiB
Diff

Remove dependencies on xwin and zig. We're not offering cross-compilation
options using these crates.
diff --git a/Cargo.toml b/Cargo.toml
index 6704e46..ff126a9 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -83,16 +83,6 @@ version = "0.1.16"
[dependencies.cargo-options]
version = "0.7.2"
-[dependencies.cargo-xwin]
-version = "0.16.2"
-optional = true
-default-features = false
-
-[dependencies.cargo-zigbuild]
-version = "0.18.0"
-optional = true
-default-features = false
-
[dependencies.cargo_metadata]
version = "0.18.0"
@@ -321,8 +311,6 @@ version = "5.0.0"
[features]
cli-completion = ["dep:clap_complete_command"]
cross-compile = [
- "zig",
- "xwin",
]
default = [
"full",
@@ -341,7 +329,6 @@ log = ["tracing-subscriber"]
native-tls = [
"dep:native-tls",
"ureq?/native-tls",
- "cargo-xwin?/native-tls",
"dep:rustls-pemfile",
]
password-storage = [
@@ -351,7 +338,6 @@ password-storage = [
rustls = [
"dep:rustls",
"ureq?/tls",
- "cargo-xwin?/rustls-tls",
"dep:rustls-pemfile",
]
scaffolding = [
@@ -369,5 +355,3 @@ upload = [
"wild",
"dep:dirs",
]
-xwin = ["cargo-xwin"]
-zig = ["cargo-zigbuild"]