guix/gnu/packages/patches/lirc-reproducible-build.patch
Tobias Geerinckx-Rice ec3226c398
gnu: lirc: Update to 0.10.2.
* gnu/packages/lirc.scm (lirc): Update to 0.10.2.
[arguments]: Add a new 'build-reproducibly phase to partially replace…
* gnu/packages/patches/lirc-reproducible-build.patch: …this updated file.
2023-01-15 01:00:00 +01:00

36 lines
1.4 KiB
Diff

Build Lirc reproducibly.
https://sourceforge.net/p/lirc/tickets/301/
https://sourceforge.net/p/lirc/git/merge-requests/33/
https://sourceforge.net/p/lirc/git/merge-requests/34/
https://sourceforge.net/p/lirc/git/merge-requests/36/
diff -Naur lirc-0.10.2a/python-pkg/lirc/database.py lirc-0.10.2/python-pkg/lirc/database.py
--- lirc-0.10.2a/python-pkg/lirc/database.py 1970-01-01 01:00:01.000000000 +0100
+++ lirc-0.10.2/python-pkg/lirc/database.py 2023-01-20 14:23:29.414088668 +0100
@@ -160,7 +160,7 @@
d['device_hint'] = hint
configs = {}
- for path in glob.glob(configdir + '/*.conf'):
+ for path in sorted(glob.glob(configdir + '/*.conf')):
with open(path) as f:
cf = yaml.load(f.read(), Loader = Loader)
configs[cf['config']['id']] = cf['config']
diff -Naur lirc-0.10.2a/tools/lirc-lsplugins.cpp lirc-0.10.2/tools/lirc-lsplugins.cpp
--- lirc-0.10.2a/tools/lirc-lsplugins.cpp 1970-01-01 01:00:01.000000000 +0100
+++ lirc-0.10.2/tools/lirc-lsplugins.cpp 2023-01-20 14:24:42.719085612 +0100
@@ -413,10 +413,9 @@
static void print_yaml_header(void)
{
static const char* const YAML_HEADER =
- "#\n# Generated by lirc-lsplugins --yaml (%s) at %s#\n ";
- const time_t now = time(NULL);
+ "#\n# Generated by lirc-lsplugins --yaml (%s)#\n ";
- printf(YAML_HEADER, VERSION, ctime(&now));
+ printf(YAML_HEADER, VERSION);
printf("\ndrivers:\n");
}