guix/gnu/packages/patches/libaio-32bit-test.patch
Andreas Enge 483124bc48
gnu: libaio: Fix tests on 32 bit systems.
* gnu/packages/patches/libaio-32bit-test.patch: New file.
* gnu/packages/linux.scm (libaio): Add patch.
* gnu/local.mk (dist_patch_DATA): Register patch.
2023-03-18 10:36:22 +01:00

27 lines
626 B
Diff

This fix comes from an upstream pull request, see
https://pagure.io/libaio/pull-request/22#commit_list
diff --git a/harness/cases/23.t b/harness/cases/23.t
index cc5a8a1..9bbb05c 100644
--- a/harness/cases/23.t
+++ b/harness/cases/23.t
@@ -72,7 +72,7 @@ static void fail_errno(const char *format, ...)
static void *thrproc2(void *arg)
{
for (;;) {
- off_t offset = 0;
+ off64_t offset = 0;
pthread_barrier_wait(&barrier);
if (exiting)
@@ -92,7 +92,7 @@ static void *thrproc3(void *arg)
{
for (;;) {
char c;
- off_t offset = 0;
+ off64_t offset = 0;
pthread_barrier_wait(&barrier);
if (exiting)