guix/gnu/packages/patches/go-fix-script-tests.patch
Sarah Morgensen e3e4cbb93f
gnu: Add go-1.16.
Add go@1.16 as a non-default go. Changes from 1.14: Use now-supported GO_LDSO
configuration option for setting the interpreter. Bootstrap with gccgo on
platforms which do not support go-1.4. Fix and re-enable cmd/go script tests.
Fix typo in cgoldflags patch. Break out tests into "check" phase. Remove
references to perl to reduce closure size by ~10%. Set GOCACHE so go doesn't
attempt to access $HOME.

* gnu/packages/patches/go-fix-script-tests.patch: New file.
* local.mk (dist_patch_DATA): Register it.
* gnu/packages/golang.scm (go-1.16): New variable. Use the patch.

Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
2021-06-28 22:19:50 +03:00

19 lines
826 B
Diff

Make library/header paths visible to cmd/go script tests, which is necessary for
cgo/gccgo tests to work correctly
diff --git a/src/cmd/go/script_test.go b/src/cmd/go/script_test.go
index dfaa40548e..9d0f0e9bcd 100644
--- a/src/cmd/go/script_test.go
+++ b/src/cmd/go/script_test.go
@@ -100,6 +100,10 @@ const (
var extraEnvKeys = []string{
"SYSTEMROOT", // must be preserved on Windows to find DLLs; golang.org/issue/25210
"WINDIR", // must be preserved on Windows to be able to run PowerShell command; golang.org/issue/30711
+ "CPATH",
+ "C_INCLUDE_PATH",
+ "CPLUS_INCLUDE_PATH",
+ "LIBRARY_PATH",
"LD_LIBRARY_PATH", // must be preserved on Unix systems to find shared libraries
"CC", // don't lose user settings when invoking cgo
"GO_TESTING_GOTOOLS", // for gccgo testing