guix/gnu/packages/patches/clang-runtime-3.7-fix-build-with-python3.patch
Greg Hogan 3485984a09
gnu: llvm-3.7, llvm-3.8: Fix build with gcc.
* gnu/packages/patches/clang-runtime-3.7-fix-build-with-python3.patch,
gnu/packages/patches/llvm-3.x.1-fix-build-with-gcc.patch: New files.
* gnu/packages/llvm.scm (clang-runtime-3.7, llvm-3.7, llvm-3.8): Use patches.
* gnu/local.mk: Register patches.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
2022-07-12 01:17:45 +02:00

17 lines
595 B
Diff

Patch based on changes from
https://github.com/llvm/llvm-project/commit/c1fde4fa943fd03a3d40bc5d32b9e0045fd29208
diff --git a/lib/sanitizer_common/scripts/gen_dynamic_list.py b/lib/sanitizer_common/scripts/gen_dynamic_list.py
index 5ea2ca1..d7bc287 100755
--- a/lib/sanitizer_common/scripts/gen_dynamic_list.py
+++ b/lib/sanitizer_common/scripts/gen_dynamic_list.py
@@ -100,7 +100,7 @@ def main(argv):
print('global:')
result.sort()
for f in result:
- print(' ' + f.encode('utf-8') + ';')
+ print(u' %s;' % f)
if args.version_list:
print('local:')
print(' *;')