5f3f703918
* gnu/packages/patches/glibc-bootstrap-system.patch, gnu/packages/patches/glibc-supported-locales.patch: Adjust for glibc 2.29. * gnu/packages/patches/glibc-2.28-supported-locales.patch, gnu/packages/patches/glibc-CVE-2019-7309.patch, gnu/packages/patches/glibc-CVE-2019-9169.patch, gnu/packages/patches/glibc-2.29-git-updates.patch: New files. * gnu/local.mk (dist_patch_DATA): Adjust accordingly. * gnu/packages/base.scm (glibc): Update to 2.29. [source](patches): Add 'glibc-CVE-2019-7309.patch', 'glibc-CVE-2019-9169.patch', and 'glibc-2.29-git-updates.patch'. Remove 'glibc-hurd-magic-pid.patch'. [native-inputs]: Add PYTHON-MINIMAL. (glibc-2.28): New public variable. * gnu/packages/commencement.scm (expat-sans-tests, python-boot0): New variables. (glibc-final-with-bootstrap-bash)[native-inputs]: Add PYTHON-BOOT0. * gnu/packages/python.scm (python-3.7)[arguments]: Disable test that fails with glibc 2.29.
22 lines
823 B
Diff
22 lines
823 B
Diff
Fix <https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-9169>.
|
|
|
|
Taken from this upstream commit, sans ChangeLog updates:
|
|
https://sourceware.org/git/gitweb.cgi?p=glibc.git;a=commitdiff;h=583dd860d5b833037175247230a328f0050dbfe9
|
|
|
|
diff --git a/posix/regexec.c b/posix/regexec.c
|
|
index 91d5a797b8..084b1222d9 100644
|
|
--- a/posix/regexec.c
|
|
+++ b/posix/regexec.c
|
|
@@ -1293,8 +1293,10 @@ proceed_next_node (const re_match_context_t *mctx, Idx nregs, regmatch_t *regs,
|
|
else if (naccepted)
|
|
{
|
|
char *buf = (char *) re_string_get_buffer (&mctx->input);
|
|
- if (memcmp (buf + regs[subexp_idx].rm_so, buf + *pidx,
|
|
- naccepted) != 0)
|
|
+ if (mctx->input.valid_len - *pidx < naccepted
|
|
+ || (memcmp (buf + regs[subexp_idx].rm_so, buf + *pidx,
|
|
+ naccepted)
|
|
+ != 0))
|
|
return -1;
|
|
}
|
|
}
|