9270298f75
gnu/packages/ruby.scm (ruby-puma): New variable. gnu/packages/patches/ruby-puma-ignore-broken-test.patch: New file. gnu/local.mk (dist_patch_DATA): Add it.
13 lines
442 B
Diff
13 lines
442 B
Diff
diff --git a/test/test_integration.rb b/test/test_integration.rb
|
|
index d9b189c..6e21180 100644
|
|
--- a/test/test_integration.rb
|
|
+++ b/test/test_integration.rb
|
|
@@ -115,7 +115,7 @@ class TestIntegration < Test::Unit::TestCase
|
|
assert_kind_of Thread, t.join(1), "server didn't stop"
|
|
end
|
|
|
|
- def test_phased_restart_via_pumactl
|
|
+ def no_test_phased_restart_via_pumactl
|
|
if Puma.jruby? || Puma.windows?
|
|
assert true
|
|
return
|