guix/gnu/packages/patches/python-3.4-fix-tests.patch
Leo Famulari 72df668061
gnu: python-3: Update to python-3.5.2.
* gnu/packages/patches/python-3.4-fix-tests.patch,
gnu/packages/patches/python-3.5-fix-tests.patch: New files.
* gnu/local.mk (dist_patch_DATA): Add them.
* gnu/packages/patches/python-fix-tests.patch: Move python-3.4 specific
hunk to 'gnu/packages/patches/python-3.4-fix-tests.patch'.
* gnu/packages/python.scm (python-3.5): New variable.
(python-3.4): Inherit from python-3.5.
[source]: Use 'gnu/packages/patches/python-3.4-fix-tests.patch'.
(python-3): Point to python-3.5.

Co-authored-by: Diane Trout <diane@ghic.org>
Co-authored-by: Christopher Allan Webber <cwebber@dustycloud.org>
2016-08-29 21:44:15 -04:00

13 lines
761 B
Diff

--- Lib/test/test_posixpath.py 2014-03-01 05:46:56.984311000 +0100
+++ Lib/test/test_posixpath.py 2014-03-07 00:59:20.888311000 +0100
@@ -319,7 +319,11 @@
del env['HOME']
home = pwd.getpwuid(os.getuid()).pw_dir
# $HOME can end with a trailing /, so strip it (see #17809)
- self.assertEqual(posixpath.expanduser("~"), home.rstrip("/"))
+ # The Guix builders have '/' as a home directory, so
+ # home.rstrip("/") will be an empty string and the test will
+ # fail. Let's just disable it since it does not really make
+ # sense with such a bizarre setup.
+ # self.assertEqual(posixpath.expanduser("~"), home.rstrip("/"))