2e0ed79118
* gnu/packages/patches/emacs-next-native-comp-driver-options.patch: Add file. * gnu/packages/patches/emacs-next-exec-path.patch: Add file. * gnu/local.mk (dist_patch_DATA): Register them here. * gnu/packages/emacs.scm (emacs-next-minimal)[origin](patches): Include the same patches as emacs-minimal, save for the variants specific to emacs-next introduced above. Co-Authored-By: Nicolas Graves <ngraves@ngraves.fr> Fixes: ‘emacs-next’ is almost unusable <https://bugs.gnu.org/66227>
18 lines
953 B
Diff
18 lines
953 B
Diff
Do not capture the build-time value of $PATH in the 'emacs' executable
|
|
since this can noticeably increase the size of the closure of Emacs
|
|
with things like GCC being referenced.
|
|
|
|
Index: emacs-next/lisp/loadup.el
|
|
===================================================================
|
|
--- emacs-next.orig/lisp/loadup.el
|
|
+++ emacs-next/lisp/loadup.el
|
|
@@ -599,7 +599,8 @@ lost after dumping")))
|
|
((equal dump-mode "dump") "emacs")
|
|
((equal dump-mode "bootstrap") "emacs")
|
|
((equal dump-mode "pbootstrap") "bootstrap-emacs.pdmp")
|
|
- (t (error "Unrecognized dump mode %s" dump-mode)))))
|
|
+ (t (error "Unrecognized dump mode %s" dump-mode))))
|
|
+ (exec-path nil))
|
|
(when (and (featurep 'native-compile)
|
|
(equal dump-mode "pdump"))
|
|
;; Don't enable this before bootstrap is completed, as the
|