132ddca5a4
* gnu/packages/freedesktop.scm (elogind): Update to 252.9. [source]: Replace elogind-revert-polkit-detection.patch with elogind-fix-rpath.patch in patches. [configure-flags]: Add the dbussystemservicedir, dbussessionservicedir, dbussystemservicedir and dbus-interfaces-dir flags. [phases] <use-global-hook-directory> Update list of patched files. <adjust-tests> Update substitutions, and skip the copy_holes test. [native-inputs]: Add python-jinja2. [inputs]: Add util-linux:lib. * gnu/services/desktop.scm (elogind-dbus-service) <elogind-dbus-service-wrapper>: Add a symlink to elogind's share/dbus-1/system.d to expose D-Bus policy configurations. * gnu/tests/desktop.scm (run-elogind-test): Adjust expected result for the new "linger" value. * gnu/packages/patches/elogind-revert-polkit-detection.patch: Delete file. * gnu/packages/patches/elogind-fix-rpath.patch: New file. * gnu/local.mk (dist_patch_DATA): Update. Series-to: 64938@debbugs.gnu.org Series-prefix: elogind-updates Series-version: 2 Series-changes: 2 - Fix elogind system test - Install D-Bus policy files in elogind-dbus-service-wrapper - Remove duplicate 'dbussystemservicedir' configure flag
60 lines
2.1 KiB
Diff
60 lines
2.1 KiB
Diff
Retrieved from https://github.com/elogind/elogind/issues/258
|
|
|
|
From: Mark Hindley <mark@hindley.org.uk>
|
|
Date: Wed, 24 May 2023 10:39:41 +0100
|
|
Subject: Fixup_executable_rpath
|
|
|
|
./meson.build sets
|
|
|
|
install_rpath : rootlibexecdir
|
|
|
|
however src/shared/meson.build sets
|
|
|
|
libshared = shared_library(
|
|
[snip]
|
|
install_dir : rootpkglibdir
|
|
)
|
|
---
|
|
meson.build | 8 ++++----
|
|
1 file changed, 4 insertions(+), 4 deletions(-)
|
|
|
|
diff --git a/meson.build b/meson.build
|
|
index 694a2fd..a575f69 100644
|
|
--- a/meson.build
|
|
+++ b/meson.build
|
|
@@ -2903,7 +2903,7 @@ executable('elogind',
|
|
dependencies : [threads,
|
|
libacl,
|
|
libudev],
|
|
- install_rpath : rootlibexecdir,
|
|
+ install_rpath : rootpkglibdir,
|
|
install : true,
|
|
install_dir : rootlibexecdir)
|
|
|
|
@@ -2913,7 +2913,7 @@ exe = executable('loginctl',
|
|
link_with : [libshared],
|
|
dependencies : [threads,
|
|
libudev],
|
|
- install_rpath : rootlibexecdir,
|
|
+ install_rpath : rootpkglibdir,
|
|
install : true,
|
|
install_dir : rootbindir)
|
|
public_programs += [exe]
|
|
@@ -2923,7 +2923,7 @@ exe = executable('elogind-inhibit',
|
|
include_directories : includes,
|
|
link_with : [libshared],
|
|
dependencies : [threads],
|
|
- install_rpath : rootlibexecdir,
|
|
+ install_rpath : rootpkglibdir,
|
|
install : true,
|
|
install_dir : rootbindir)
|
|
public_programs += [exe]
|
|
@@ -4283,7 +4283,7 @@ executable('elogind-uaccess-command',
|
|
libshared],
|
|
dependencies: [libacl,
|
|
libudev],
|
|
- install_rpath : rootlibexecdir,
|
|
+ install_rpath : rootpkglibdir,
|
|
install : true,
|
|
install_dir : rootlibexecdir)
|
|
#endif // 0
|