c1090dd4d6
* gnu/packages/cpp.scm (bloomberg-bde): Update to 3.118.0.1. [source](origin): Update test deletion list. [arguments]<#:configure-flags>: Update from C++17 to C++20. [supported-systems]: Only support x86_64-linux. * gnu/packages/patches/bloomberg-bde-cmake-module-path.patch: Rebase. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
14 lines
495 B
Diff
14 lines
495 B
Diff
This package requires CMAKE_MODULE_PATH be set by the calling process. This
|
|
patch uses the CMAKE_PREFIX_PATH passed from Guix as the search path for
|
|
locating the bloomberg-bde-tools CMake modules.
|
|
|
|
--- a/CMakeLists.txt
|
|
+++ b/CMakeLists.txt
|
|
@@ -14,6 +14,7 @@ else()
|
|
if (NOT CMAKE_MODULE_PATH)
|
|
message(FATAL "Please specify path to BDE cmake modules.")
|
|
endif()
|
|
+ string(REPLACE ":" "cmake/;" CMAKE_MODULE_PATH "$ENV{CMAKE_PREFIX_PATH}cmake/")
|
|
|
|
include(bde_workspace)
|
|
|