guix/gnu/packages/patches/clisp-glibc-2.26.patch
Kei Kebreau 75033216ea
gnu: clisp: Fix build with glibc 2.26.
* gnu/packages/patches/clisp-glibc-2.26.patch: New file.
* gnu/local.mk (dist_patch_DATA): Add it.
* gnu/packages/lisp.scm (clisp)[source]: Use it.
2018-01-20 21:48:47 -05:00

21 lines
915 B
Diff

This patch comes from Debian.
Description: cfree is not present in glibc-2.26, stop wrapping it
Author: Adam Conrad <adconrad@ubuntu.com>
Bug: https://sourceforge.net/p/clisp/bugs/717/
Bug-Debian: https://bugs.debian.org/880686
Applied-Upstream: https://sourceforge.net/p/clisp/clisp/ci/3bc928712d150ff1e5f6b2bfb7838655f3ff52fa/
Reviewed-By: Sébastien Villemot <sebastien@debian.org>
Last-Update: 2017-11-27
--- clisp-2.49.20170913.orig/modules/bindings/glibc/linux.lisp
+++ clisp-2.49.20170913/modules/bindings/glibc/linux.lisp
@@ -649,7 +649,6 @@
(def-call-out calloc (:arguments (nmemb size_t) (size size_t))
(:return-type c-pointer))
(def-call-out free (:arguments (ptr c-pointer)) (:return-type nil))
-(def-call-out cfree (:arguments (ptr c-pointer)) (:return-type nil))
(def-call-out valloc (:arguments (size size_t)) (:return-type c-pointer))
(def-call-out abort (:arguments) (:return-type nil))