guix/gnu/packages/patches/mupdf-CVE-2016-9136.patch
Leo Famulari 667e777b4e
gnu: mupdf: Fix CVE-2016-{7504,7505,7506,7563,7564,9017,9136} in bundled mujs.
* gnu/packages/patches/mupdf-CVE-2016-7504.patch,
gnu/packages/patches/mupdf-CVE-2016-7505.patch
gnu/packages/patches/mupdf-CVE-2016-7506.patch
gnu/packages/patches/mupdf-CVE-2016-7563.patch
gnu/packages/patches/mupdf-CVE-2016-7564.patch
gnu/packages/patches/mupdf-CVE-2016-9017.patch
gnu/packages/patches/mupdf-CVE-2016-9136.patch: New files.
* gnu/local.mk (dist_patch_DATA): Add them.
* gnu/packages/pdf.scm (mupdf)[source]: Use them.
2016-11-08 11:03:14 -05:00

33 lines
975 B
Diff

Fix CVE-2016-9136:
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2016-9136
http://bugs.ghostscript.com/show_bug.cgi?id=697244
Patch copied from upstream source repository:
http://git.ghostscript.com/?p=mujs.git;a=commitdiff;h=a0ceaf5050faf419401fe1b83acfa950ec8a8a89
From a0ceaf5050faf419401fe1b83acfa950ec8a8a89 Mon Sep 17 00:00:00 2001
From: Tor Andersson <tor.andersson@artifex.com>
Date: Mon, 31 Oct 2016 13:05:37 +0100
Subject: [PATCH] Fix 697244: Check for incomplete escape sequence at end of
input.
---
jslex.c | 1 +
1 file changed, 1 insertion(+)
diff --git a/jslex.c b/jslex.c
index cbd0eeb..aaafdac 100644
--- a/thirdparty/mujs/jslex.c
+++ b/thirdparty/mujs/jslex.c
@@ -377,6 +377,7 @@ static int lexescape(js_State *J)
return 0;
switch (J->lexchar) {
+ case 0: jsY_error(J, "unterminated escape sequence");
case 'u':
jsY_next(J);
if (!jsY_ishex(J->lexchar)) return 1; else { x |= jsY_tohex(J->lexchar) << 12; jsY_next(J); }
--
2.10.2