b5d9beaa1a
* gnu/packages/patches/xf86-input-synaptics-glibc-2.20.patch: New file. * gnu-system.am (dist_patch_DATA): Add it. * gnu/packages/xorg.scm (xf86-input-synaptics): Use it. Improve synopsis and description.
63 lines
2.3 KiB
Diff
63 lines
2.3 KiB
Diff
Allow builds with libc 2.20.
|
|
Patch from <https://raw.githubusercontent.com/openembedded/oe-core/master/meta/recipes-graphics/xorg-driver/xf86-input-synaptics/always_include_xorg_server.h.patch>.
|
|
|
|
From 96e60a4ea242d2decf109835981ae186cc36f642 Mon Sep 17 00:00:00 2001
|
|
From: Peter Hutterer <peter.hutterer@who-t.net>
|
|
Date: Fri, 29 Aug 2014 07:57:41 +1000
|
|
Subject: Include xorg-server.h to fix build errors on newest glibc
|
|
|
|
In file included from /usr/include/string.h:634:0,
|
|
from /usr/include/xorg/os.h:53,
|
|
from /usr/include/xorg/misc.h:115,
|
|
from /usr/include/xorg/xf86str.h:37,
|
|
from /usr/include/xorg/xf86Xinput.h:54,
|
|
from synproto.h:36,
|
|
from synproto.c:24:
|
|
/usr/include/xorg/os.h:579:1: error: expected identifier or '(' before '__extension__'
|
|
strndup(const char *str, size_t n);
|
|
|
|
See http://lists.freedesktop.org/archives/xorg-devel/2014-July/043070.html
|
|
|
|
Signed-off-by: Peter Hutterer <peter.hutterer@who-t.net>
|
|
|
|
Status: Backport
|
|
|
|
Index: xf86-input-synaptics-1.8.0/src/eventcomm.h
|
|
===================================================================
|
|
--- xf86-input-synaptics-1.8.0.orig/src/eventcomm.h 2014-08-28 18:40:28.628070587 -0700
|
|
+++ xf86-input-synaptics-1.8.0/src/eventcomm.h 2014-08-28 18:40:28.620070587 -0700
|
|
@@ -27,6 +27,8 @@
|
|
#ifndef _EVENTCOMM_H_
|
|
#define _EVENTCOMM_H_
|
|
|
|
+#include <xorg-server.h>
|
|
+
|
|
#include <linux/input.h>
|
|
#include <linux/version.h>
|
|
#include <xf86Xinput.h>
|
|
Index: xf86-input-synaptics-1.8.0/src/ps2comm.h
|
|
===================================================================
|
|
--- xf86-input-synaptics-1.8.0.orig/src/ps2comm.h 2014-08-28 18:40:28.628070587 -0700
|
|
+++ xf86-input-synaptics-1.8.0/src/ps2comm.h 2014-08-28 18:40:28.620070587 -0700
|
|
@@ -22,6 +22,8 @@
|
|
#ifndef _PS2COMM_H_
|
|
#define _PS2COMM_H_
|
|
|
|
+#include <xorg-server.h>
|
|
+
|
|
#include <unistd.h>
|
|
#include <sys/ioctl.h>
|
|
#include "xf86_OSproc.h"
|
|
Index: xf86-input-synaptics-1.8.0/src/synproto.h
|
|
===================================================================
|
|
--- xf86-input-synaptics-1.8.0.orig/src/synproto.h 2014-08-28 18:40:28.628070587 -0700
|
|
+++ xf86-input-synaptics-1.8.0/src/synproto.h 2014-08-28 18:40:28.624070587 -0700
|
|
@@ -31,6 +31,8 @@
|
|
#include "config.h"
|
|
#endif
|
|
|
|
+#include <xorg-server.h>
|
|
+
|
|
#include <unistd.h>
|
|
#include <sys/ioctl.h>
|
|
#include <xf86Xinput.h>
|