e7de5ac0d5
* gnu/packages/video.scm (ffmpeg): Add upstream patch and re-enable tests. * gnu/packages/patches/ffmpeg-check.patch: New file. * gnu-system.am (dist_patch_DATA): Register patch.
15 lines
476 B
Diff
15 lines
476 B
Diff
See https://trac.ffmpeg.org/ticket/3177 .
|
|
|
|
diff --git a/libavcodec/cabac.c b/libavcodec/cabac.c
|
|
index 29b188b..dff0a91 100644
|
|
--- a/libavcodec/cabac.c
|
|
+++ b/libavcodec/cabac.c
|
|
@@ -301,7 +301,7 @@ STOP_TIMER("get_cabac_bypass")
|
|
|
|
for(i=0; i<SIZE; i++){
|
|
START_TIMER
|
|
- if( (r[i]&1) != get_cabac(&c, state) )
|
|
+ if( (r[i]&1) != get_cabac_noinline(&c, state) )
|
|
av_log(NULL, AV_LOG_ERROR, "CABAC failure at %d\n", i);
|
|
STOP_TIMER("get_cabac")
|
|
}
|