guix/gnu/packages/patches/boost-fix-transitive-linking.patch
Greg Hogan 94cf367634
gnu: boost: Patch transitive linking bug.
* gnu/packages/patches/boost-fix-transitive-linking.patch: New file.
* gnu/local.mk (dist_patch_DATA): Add it.
* gnu/packages/boost.scm (boost)[source]: Use it.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
2021-01-26 23:32:54 +01:00

17 lines
538 B
Diff

Patch from https://github.com/boostorg/boost_install/issues/47
which should be included in the Boost 1.76 release.
This patch prevents CMake from explicitly linking against Boost dependencies
when building against the shared Boost libraries.
--- a/tools/boost_install/boost-install.jam
+++ b/tools/boost_install/boost-install.jam
@@ -483,7 +483,7 @@ rule generate-cmake-variant- ( target : sources * : properties * )
.info " deps3=" $(deps3) ;
- if $(deps3)
+ if $(deps3) && $(link) = static
{
print.text