guix/gnu/packages/patches/elixir-path-length.patch
Robert Smith 2f87048dbe
gnu: elixir: Update to 1.8.1.
* gnu/packages/elixir.scm (elixir): Update to 1.8.1.
[source](patches): New field.
[home-page]: Use HTTPS.
* gnu/packages/patches/elixir-path-length.patch: New file.
* gnu/local.mk (dist_patch_DATA): Add it.

Signed-off-by: Marius Bakke <mbakke@fastmail.com>
2019-03-21 20:48:12 +01:00

16 lines
591 B
Diff

In the package definition the call to the command 'git' is substituted with
the full path to the git executable. This change causes the mix formatting tool
to complain that the line is too long. This workaround reformats the file
after the substitution is made.
--- a/Makefile
+++ b/Makefile
@@ -213,6 +213,7 @@
TEST_ERLS = $(addprefix $(TEST_EBIN)/, $(addsuffix .beam, $(basename $(notdir $(wildcard $(TEST_ERL)/*.erl)))))
test_formatted: compile
+ bin/elixir bin/mix format lib/mix/lib/mix/scm/git.ex
bin/elixir bin/mix format --check-formatted
test_erlang: compile $(TEST_ERLS)