c30fa177f3
* gnu/packages/machine-learning.scm (xgboost, python-xgboost): Update to 1.5.2. (python-xgboost)[arguments]: Enable previously failing test. * gnu/packages/patches/xgboost-use-system-dmlc-core.patch: Update patch. Signed-off-by: Ricardo Wurmus <rekado@elephly.net>
35 lines
1.2 KiB
Diff
35 lines
1.2 KiB
Diff
# This patch was imported from Debian: https://sources.debian.org/src/xgboost/1.5.1-1/debian/patches/cmake-dmlc-core.patch/
|
|
|
|
Index: xgboost/CMakeLists.txt
|
|
===================================================================
|
|
--- xgboost.orig/CMakeLists.txt
|
|
+++ xgboost/CMakeLists.txt
|
|
@@ -164,7 +164,9 @@ endif (USE_NCCL)
|
|
|
|
# dmlc-core
|
|
msvc_use_static_runtime()
|
|
-add_subdirectory(${xgboost_SOURCE_DIR}/dmlc-core)
|
|
+add_library(dmlc SHARED IMPORTED)
|
|
+find_library(DMLC_LIBRARY dmlc)
|
|
+set_property(TARGET dmlc PROPERTY IMPORTED_LOCATION "${DMLC_LIBRARY}")
|
|
|
|
if (MSVC)
|
|
if (TARGET dmlc_unit_tests)
|
|
@@ -222,7 +224,7 @@ set_target_properties(runxgboost PROPERT
|
|
#-- End CLI for xgboost
|
|
|
|
# Common setup for all targets
|
|
-foreach(target xgboost objxgboost dmlc runxgboost)
|
|
+foreach(target xgboost objxgboost runxgboost)
|
|
xgboost_target_properties(${target})
|
|
xgboost_target_link_libraries(${target})
|
|
xgboost_target_defs(${target})
|
|
@@ -273,7 +275,7 @@ install(DIRECTORY ${xgboost_SOURCE_DIR}/
|
|
#
|
|
# https://github.com/dmlc/xgboost/issues/6085
|
|
if (BUILD_STATIC_LIB)
|
|
- set(INSTALL_TARGETS xgboost runxgboost objxgboost dmlc)
|
|
+ set(INSTALL_TARGETS xgboost runxgboost objxgboost)
|
|
else (BUILD_STATIC_LIB)
|
|
set(INSTALL_TARGETS xgboost runxgboost)
|
|
endif (BUILD_STATIC_LIB)
|