guix/gnu/packages/patches/ruby-nokogiri.patch
gemmaro e897569778
gnu: ruby-nokogiri: Update to 1.15.2.
* gnu/packages/ruby.scm (ruby-nokogiri): Update to 1.15.2.
  [source]<uri>: Use Git repository.
  <patches>: apply a patch to disable unneeded test setups.
  [arguments]: Enable check by running plain minitest.
  [home-page]: Update to current URL.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
2023-06-24 16:25:50 +02:00

30 lines
907 B
Diff

Description: Removed some unnecessary test setup such as SimpleCov and
minitest-reporters.
diff --git a/test/helper.rb b/test/helper.rb
index ed3133c6..4f5d4f1b 100644
--- a/test/helper.rb
+++ b/test/helper.rb
@@ -13,22 +13,10 @@
# - NOKOGIRI_GC: read more in test/test_memory_leak.rb
#
-require "simplecov"
-SimpleCov.start do
- add_filter "/test/"
- enable_coverage :branch
-end
-
$VERBOSE = true
require "minitest/autorun"
require "minitest/benchmark"
-require "minitest/reporters"
-
-nokogiri_minitest_reporters_options = { color: true, slow_count: 10, detailed_skip: false }
-nokogiri_minitest_reporters_options[:fast_fail] = true if ENV["NOKOGIRI_TEST_FAIL_FAST"]
-puts "Minitest::Reporters options: #{nokogiri_minitest_reporters_options}"
-Minitest::Reporters.use!(Minitest::Reporters::DefaultReporter.new(nokogiri_minitest_reporters_options))
require "fileutils"
require "tempfile"