guix/gnu/packages/patches/rocm-comgr-3.1.0-dependencies.patch
John Kehayias 15f9870eb3
gnu: rocm: Update to 5.6.0.
Update all of the ROCm packages at the same time as they share a version
number and should be upgraded together, including llvm-for-rocm.

* gnu/packages/llvm.scm (llvm-for-rocm): Update to 5.6.0.
[source]{patches}: Remove unneeded patches (linkdl and remove-isystem-usr-include).
* gnu/packages/rocm.scm (rocm-cmake, roct-thunk-interface): Update
to 5.6.0.
(rocclr-src): Update to 5.6.0.
[source]{patches}: Add enable-gfx800 patch.
(rocm-device-libs):  Update to 5.6.0.
[inputs]: Update style.
(rocm-comgr): Update to 5.6.0.
[inputs]: Remove lld.  Update style.
(rocr-runtime): Update to 5.6.0.
[arguments]: Use gexps.  Remove configure-flags.  Add add-rocm-device-lib-path
phase.
[inputs]: Add libdrm.  Update style.
[native-inputs]: Add pkg-config.  Update style.
(rocm-opencl-runtime): Update to 5.6.0.
[source]{patches}: Remove noopencl patch.
[arguments]{configure-flags}: Add BUILD_ICD=OFF and
FILE_REORG_BACKWARD_COMPATIBILITY=OFF flags.
[inputs]: Add opencl-headers.
(rocminfo): Update to 5.6.0.
[arguments]: Use gexps.  Use search-input-file instead of assoc-ref and which.
(rocm-bandwidth-test): Update to 5.6.0.
[source]{patches}: Add fix-includes patch.
* gnu/packages/patches/rocm-comgr-3.1.0-dependencies.patch,
gnu/packages/patches/rocm-opencl-runtime-4.3-noclinfo.patch: Update patches.
* gnu/packages/patches/llvm-roc-4.0.0-remove-isystem-usr-include.patch,
gnu/packages/patches/llvm-roc-5.0.0-linkdl.patch,
gnu/packages/patches/rocm-opencl-runtime-4.3-noopencl.patch: Delete files.
* gnu/packages/patches/rocm-bandwidth-test-5.5.0-fix-includes.patch,
gnu/packages/patches/rocclr-5.6.0-enable-gfx800.patch: New files.
* gnu/local.mk (dist_patch_DATA): Update patches.
2023-07-11 12:21:00 -04:00

57 lines
1.3 KiB
Diff

See https://github.com/RadeonOpenCompute/ROCm-CompilerSupport/pull/25 for
original patch.
From c65cba2e73f9118e128b9ab7e655ee0f8a7798e7 Mon Sep 17 00:00:00 2001
From: Craig Andrews <candrews@integralblue.com>
Date: Sun, 1 Mar 2020 19:24:22 -0500
Subject: [PATCH] Link additional required LLVM libraries
Without these additional required dependencies, linking fails with errors such as:
`undefined reference to llvm::errs()'`
---
CMakeLists.txt | 20 ++++++++++++++++++--
1 file changed, 18 insertions(+), 2 deletions(-)
diff --git a/lib/comgr/CMakeLists.txt b/lib/comgr/CMakeLists.txt
index fd3ae4a..131e581 100644
--- a/lib/comgr/CMakeLists.txt
+++ b/lib/comgr/CMakeLists.txt
@@ -322,7 +322,11 @@ install(FILES
if(TARGET clangFrontendTool)
set(CLANG_LIBS
- clangFrontendTool)
+ clangFrontendTool
+ clangFrontend
+ clangBasic
+ clangDriver
+ clangSerialization)
else()
set(CLANG_LIBS
clang-cpp)
@@ -337,8 +341,23 @@ if (LLVM_LINK_LLVM_DYLIB)
else()
llvm_map_components_to_libnames(LLVM_LIBS
${LLVM_TARGETS_TO_BUILD}
+ Option
DebugInfoDWARF
- Symbolize)
+ Symbolize
+ Support
+ Object
+ TargetParser
+ Bitreader
+ BitWriter
+ MC
+ MCParser
+ MCDisassembler
+ Core
+ IRReader
+ CodeGen
+ Linker
+ Demangle
+ BinaryFormat)
endif()
target_link_options(amd_comgr