guix/gnu/packages/patches/network-manager-meson.patch
Ludovic Courtès f862d7fb8d
gnu: network-manager: Build with Meson 0.60.
This is another way to address
<https://github.com/mesonbuild/meson/issues/9492> as suggested by
Nirbheek Chauhan and Paolo Bonzini.

* gnu/packages/patches/network-manager-meson.patch: New file.
* gnu/local.mk (dist_patch_DATA): Add it.
* gnu/packages/gnome.scm (network-manager)[source]: Use it.
[arguments]: Remove #:meson.
2021-11-21 23:01:15 +01:00

22 lines
761 B
Diff

Since libnm-wwan.so is not just a loadable module but also a shared library
that some plugin links against, build it as a shared library while avoiding
'-Wl,--no-undefined':
https://github.com/mesonbuild/meson/issues/9492#issuecomment-973117289
diff --git a/src/core/devices/wwan/meson.build b/src/core/devices/wwan/meson.build
index 37ef738..18ac54f 100644
--- a/src/core/devices/wwan/meson.build
+++ b/src/core/devices/wwan/meson.build
@@ -4,8 +4,9 @@ wwan_inc = include_directories('.')
linker_script = join_paths(meson.current_source_dir(), 'libnm-wwan.ver')
-libnm_wwan = shared_module(
+libnm_wwan = shared_library(
'nm-wwan',
+ override_options: ['b_lundef=false'],
sources: files(
'nm-service-providers.c',
'nm-modem-broadband.c',