guix/gnu/packages/patches/kinit-kdeinit-extra_libs.patch
Brendan Tildesley 575a03ab39
gnu: KDE Frameworks: Update all packages to 5.92.0
*  gnu/packages/kde-frameworks.scm

(extra-cmake-modules, attica, bluez-qt, breeze-icons, kapidox, karchive,
kcalendarcore, kcodecs, kconfig, kcoreaddons, kdbusaddons, kdnssd,
kguiaddons, kholidays, ki18n, kidletime, kirigami, kitemmodels,
kitemviews, kplotting, ksyntaxhighlighting, kwayland, kwidgetsaddons,
kwindowsystem, modemmanager-qt, networkmanager-qt, oxygen-icons, prison,
qqc2-desktop-style, solid, sonnet, threadweaver, kactivities, kauth,
kcompletion, kcontacts, kcrash, kdoctools, kfilemetadata, kimageformats,
kjobwidgets, knotifications, kpackage, kpty, kunitconversion, syndication,
baloo, kactivities-stats, kbookmarks, kcmutils, kconfigwidgets,
kdeclarative, kded, kdesignerplugin, kdesu, kdewebkit, kemoticons,
kglobalaccel, kiconthemes, kinit, kio, knewstuff, knotifyconfig, kparts,
kpeople, krunner, kservice, ktexteditor, ktextwidgets, kwallet, kxmlgui,
kxmlrpcclient, plasma-framework, purpose, kde-frameworkintegration,
kdelibs4support, khtml, kjs, kjsembed, kmediaplayer, kross, kdav):
Update to 5.92.0.

(extra-cmake-modules)[arguments]:
Disable failing test.
Don't run check phase after install.

(bluez): [arguments]: Enable tests.

(breeze-icons): [native-inputs]: Remove uneeded dependency libxml2, Add python-lxml, python.

(kapidox): Use python-build-system.  [native-inputs]: Remove extraneous
input.

kcalendarcore: [arguments]: Enable as many tests as possible.

(kconfig): [native-inputs]: Remove no longer needed inputs.
[arguments]: Disable failing test.

(kcoreaddons): [arguments]: Remove old hack, disable broken tests.

(ki18n): [arguments]: Disable failing tests.

(kguiaddons): [inputs]: Add new dependencies qtwayland, wayland.

(kwidgetsaddons): [arguments]: Disable another failing test.

(kwayland): [inputs]: Add plasma-wayland-protocols.
[arguments]: Enable working tests.

(knotifications): [native-inputs]: add libcanberra, libdbusmenu-qt,
qtdeclarative-5.
[arguments]: Respect tests?

(sonnet): [inputs]: Add qtdeclarative-5.

(kxmlgui): [inputs]: Add kguiaddons.

(kxmlrpcclient): [source]: Update url.

(plasma-framework): [arguments]: Enable all tests that work.
[native-inputs]: Add kdoctools.

(kpackage): [arguments]: Use substitution instead of patch.

(kio): [inputs]: Add new dependencies.
[native-inputs]: Add kdoctools.
[arguments]: Enable all tests that work.

(kdeclarative): [inputs]: Remove extraenous inputs.
[propagated-inputs]: Propagate qtdeclarative, since it always seems to
be needed.
[native-inputs]: Add dbus to skip failing test.
[arguments]: Replace check due to failing test.

(solid): [arguments]: Respect tests?.

(kdbusaddons): [arguments]: Respect tests?.
Fix patch by replacing it with a substitution instead.

(kholidays): [arguments]: Enable working test.

(ksyntaxhighlighting): [arguments]: Don't patch file that doesn't exist any more.

(kwindowsystem): [arguments]: Respect tests?.

(modemmanager-qt): [arguments]: Respect tests?.

(kauth): [arguments]: Respect tests?.

(kfilemetadata): [arguments]: A different test fails now.

(kunitconversion): [arguments]: Disable tests.

(baloo): [arguments]: Enable tests. Respect tests?.

(kconfigwidgets): Move qttools to native-inputs.

(kded): [inputs]: Remove unneeded kinit input.
[native-inputs]: Add kdoctools.

(kdesignerplugin): [inputs]: Remove extraneous inputs.
[native-inputs]: Add kdoctools.

(kglobalaccel): [inputs]: Remove extraneous inputs.

(kinit): [native-inputs]: Add kdoctools.

(knewstuff): [inputs]: Add kpackage.

(krunner): [arguments]: Disable failing tests.

(kservice): [arguments]: Enable all tests that work.
[native-inputs]: Add kdoctools.

(ktexteditor): [arguments]: Enable all tests that work.

(kwallet): [native-inputs]: Add kdoctools.

(purpose): [arguments]: Remove unneeded hack.

(kdelibs4support): Move qttools to native-inputs.
[native-inputs]: Add kdoctools.

(kcontacts): [inputs]: Add iso-codes since the tests look for some .json
files from it.
[arguments]: Disable failing tests.

(networkmanager-qt): [arguments]: Respect tests?.

* gnu/local.mk: Delete references to deleted patches:
kdbusaddons-kinit-file-name.patch
kinit-kdeinit-libpath.patch
kpackage-allow-external-paths.patch
kpackage-fix-KF5PackageMacros.cmake.patch
plasma-framework-fix-KF5PlasmaMacros.cmake.patch

* gnu/packages/patches/kdbusaddons-kinit-file-name.patch: Delete file.
* gnu/packages/patches/kinit-kdeinit-libpath.patch: Delete file.
* gnu/packages/patches/kpackage-allow-external-paths.patch: Delete file.
* gnu/packages/patches/kpackage-fix-KF5PackageMacros.cmake.patch: Delete
file.
* gnu/packages/patches/plasma-framework-fix-KF5PlasmaMacros.cmake.patch:
Delete file.

* gnu/packages/patches/kinit-kdeinit-extra_libs.patch: Fix patch.

Signed-off-by: Marius Bakke <marius@gnu.org>
2022-09-01 17:23:59 +02:00

33 lines
1.2 KiB
Diff

Search the "extra libs" in GUIX_KF5INIT_LIB_PATH (which basically is a
collection of all /lib directories). We can not hard-code the full path to the
libsKF5Plasam, since adding palse-workspace
Adopted from NixOS
pkgs/development/libraries/kde-frameworks/kinit/kdeinit-extra_libs.patch
===================================================================
--- kinit-5.32.0/src/kdeinit/kinit-5.32.0/src/kdeinit/.orig
+++ kinit-5.32.0/src/kdeinit/kinit.cpp
@@ -96,9 +96,9 @@
"libKF5Parts.5.dylib",
"libKF5Plasma.5.dylib"
#else
- "libKF5KIOCore.so.5",
- "libKF5Parts.so.5",
- "libKF5Plasma.so.5"
+ "GUIX_PKGS_KF5_KIO/lib/libKF5KIOCore.so.5",
+ "GUIX_PKGS_KF5_PARTS/lib/libKF5Parts.so.5",
+ "GUIX_PKGS_KF5_PLASMA/lib/libKF5Plasma.so.5"
#endif
};
#endif
@@ -1673,7 +1673,7 @@
#if defined(Q_OS_UNIX) && !defined(Q_OS_OSX)
if (!d.suicide && qEnvironmentVariableIsEmpty("KDE_IS_PRELINKED")) {
for (const char *extra_lib : extra_libs) {
- const QString extra = findSharedLib(QString::fromLatin1(extra_lib));
+ const QString extra = QString::fromLatin1(extra_lib);
if (!extra.isEmpty()) {
QLibrary l(extra);
l.setLoadHints(QLibrary::ExportExternalSymbolsHint);