guix/gnu/packages/patches/gcc-6-fix-buffer-size.patch
Danny Milosavljevic f2c6375449
gnu: gcc-vc4: Update to commit 0fe4b83897341742f9df65797474cb0feab4b377.
* gnu/packages/patches/gcc-6-fix-buffer-size.patch: New file.
* gnu/packages/patches/gcc-6-fix-isl-includes.patch: New file.
* gnu/local.mk (dist_patch_DATA): Add them.
* gnu/packages/embedded.scm (gcc-vc4): Update to commit
0fe4b83897341742f9df65797474cb0feab4b377.
[source]: Add the patches from above.
2020-11-16 15:02:48 +01:00

16 lines
503 B
Diff

Fixes a possible buffer overflow. (There are others)
Author: Danny Milosavljevic <dannym@scratchpost.org>
Date: 2020-11-16
--- a/gcc/gimplify.c.orig 2020-10-29 08:45:11.532479774 +0100
+++ b/gcc/gimplify.c 2020-10-29 08:45:49.584637018 +0100
@@ -5229,7 +5229,7 @@
flexibility, split it into separate input and output
operands. */
tree input;
- char buf[10];
+ char buf[12];
/* Turn the in/out constraint into an output constraint. */
char *p = xstrdup (constraint);