guix/gnu/packages/patches/emacs-kv-fix-tests.patch
Andrew Tropin 0336372296
gnu: emacs-kv: Fix build.
Build fails with emacs-next cause of copypasted test defined two times.

* gnu/packages/patches/emacs-kv-fix-tests.patch: New file.
* gnu/packages/emacs-xyz.scm (emacs-kv): Use it here.
* gnu/local.mk (dist_patch_DATA): Register it here.
2022-09-14 18:25:12 +03:00

31 lines
893 B
Diff

From 4702849bfe7462fb6c6303786dac1b670c8f0f8f Mon Sep 17 00:00:00 2001
From: Andrew Tropin <andrew@trop.in>
Date: Wed, 14 Sep 2022 09:17:31 +0300
Subject: [PATCH] remove copypasted kvaq test
---
kv-tests.el | 7 -------
1 file changed, 7 deletions(-)
diff --git a/kv-tests.el b/kv-tests.el
index 1713e5e..abd6a24 100644
--- a/kv-tests.el
+++ b/kv-tests.el
@@ -105,13 +105,6 @@
(should-not (equal "b" (kvaq "a" '((:a . :b)("a" . "b")))))
(should-not (kvaq "b" '((:a . :b)("a" . "b")))))
-(ert-deftest kvaq ()
- "Test the simple assq."
- (should (equal :b (kvaq :a '((:a . :b)("a" . "b")))))
- (should (equal 2 (kvaq 1 '((1 . 2)("a" . "b")))))
- (should-not (equal "b" (kvaq "a" '((:a . :b)("a" . "b")))))
- (should-not (kvaq "b" '((:a . :b)("a" . "b")))))
-
(ert-deftest kvaqc ()
"Test the simple assq."
(should (equal :b (kvaqc :a '((:a . :b)("a" . "b")))))
--
2.37.3