guix/gnu/packages/patches/calibre-remove-test-unrar.patch
Brendan Tildesley 5d53eec337
gnu: calibre: Update to 5.14.0.
* gnu/packages/ebook.scm (calibre): Update to 5.14.0.
[source]: Adjust the snippet to preserve some files used by the HTML reader.
[native-inputs]: Add python-pyqt-builder. Replace python2-flake8 with
python-flake8.
[inputs]: Remove chmlib, js-mathjax, python-chardet, and python-sip.  Add
python-cchardet, python-speechd, python-zeroconf, python-py7zr, python-pychm,
python-pycryptodome, libjpeg, and libjxr.  Replace all Python 2 dependencies
with their Python 3 equivalents.
[arguments]: Build with the default Python and adjust custom phases accordingly.
Adjust the 'configure' phase to changes in how Calibre uses SIP, and patch
lookup paths for libjpeg and libjxr.
Rename the 'build-extra' phase to 'install-rapydscript', and run it after the
'install' phase. Adjust it for Calibre 5.14.0.
* gnu/packages/patches/calibre-no-updates-dialog.patch,
gnu/packages/patches/calibre-remove-test-sqlite.patch,
gnu/packages/patches/calibre-remove-test-unrar.patch: Adjust patches for Calibre
5.14.0.
2021-04-09 16:09:26 -04:00

27 lines
773 B
Diff

From 9edf67191cc3655480b6fd418247709ade930b1a Mon Sep 17 00:00:00 2001
From: Brendan Tildesley <mail@brendan.scot>
Date: Thu, 25 Feb 2021 00:33:10 +1100
Subject: [PATCH] Remove test_unrar
---
src/calibre/test_build.py | 4 ----
1 file changed, 4 deletions(-)
diff --git a/src/calibre/test_build.py b/src/calibre/test_build.py
index b37fb1bcfb..0ab7aa0646 100644
--- a/src/calibre/test_build.py
+++ b/src/calibre/test_build.py
@@ -369,10 +369,6 @@ def test_file_dialog_helper(self):
from calibre.gui2.win_file_dialogs import test
test()
- def test_unrar(self):
- from calibre.utils.unrar import test_basic
- test_basic()
-
def test_7z(self):
from calibre.utils.seven_zip import test_basic
test_basic()
--
2.30.1