c55acb0732
* gnu/packages/linux.scm (bpftrace): New variable. * gnu/packages/patches/bpftrace-disable-bfd-disasm.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. Signed-off-by: Mathieu Othacehe <othacehe@gnu.org>
15 lines
381 B
Diff
15 lines
381 B
Diff
diff --git a/CMakeLists.txt b/CMakeLists.txt
|
|
index e89a6a9..a594786 100644
|
|
--- a/CMakeLists.txt
|
|
+++ b/CMakeLists.txt
|
|
@@ -126,10 +126,6 @@ find_package(LibBpf)
|
|
find_package(LibBfd)
|
|
find_package(LibOpcodes)
|
|
|
|
-if(${LIBBFD_FOUND} AND ${LIBOPCODES_FOUND})
|
|
- set(HAVE_BFD_DISASM TRUE)
|
|
-endif()
|
|
-
|
|
include(CheckIncludeFile)
|
|
check_include_file("sys/sdt.h" HAVE_SYSTEMTAP_SYS_SDT_H)
|
|
|