guix/gnu/packages/patches/mesa-skip-disk-cache-test.patch
Marius Bakke 0315b20a2c
gnu: mesa: Update to 17.0.4.
* gnu/packages/patches/mesa-skip-disk-cache-test.patch: New file.
* gnu/local.mk (dist_patch_DATA): Add it.
* gnu/packages/gl.scm (mesa): Update to 17.0.4.
[source]: Adapt URI to new directory structure.
[arguments]: End phases on #t. Remove stray whitespaces.
[home-page]: Use HTTPS.
2017-04-17 21:26:41 +02:00

21 lines
692 B
Diff

disk_cache_create() here looks up the users home directory from <pwd.h>
which resolves to "/" in the build environment. I could not find an easy
way to set the home directory to something else, so we disable this test
for now.
--- a/src/compiler/glsl/tests/cache_test.c
+++ b/src/compiler/glsl/tests/cache_test.c
@@ -137,11 +137,6 @@
unsetenv("MESA_GLSL_CACHE_DIR");
unsetenv("XDG_CACHE_HOME");
- cache = disk_cache_create();
- expect_non_null(cache, "disk_cache_create with no environment variables");
-
- disk_cache_destroy(cache);
-
/* Test with XDG_CACHE_HOME set */
setenv("XDG_CACHE_HOME", CACHE_TEST_TMP "/xdg-cache-home", 1);
cache = disk_cache_create();