guix/gnu/packages/patches/rcs-5.10.0-no-stdin.patch
Efraim Flashner d24e37f36e
gnu: rcs: Update to 5.10.0.
* gnu/packages/version-control.scm (rcs): Update to 5.10.0.
[source]: Update patches.
[arguments]: Remove field.
* gnu/packages/patches/rcs-5.9.4-noreturn.patch: Remove file.
* gnu/packages/patches/rcs-5.10.0-no-stdin.patch: Add file.
* gnu/local.mk (dist_patch_DATA): Register changes.
2020-10-23 17:45:55 +03:00

58 lines
1.6 KiB
Diff

http://git.savannah.gnu.org/cgit/rcs.git/patch/?id=8883c4f5a29be18e9ea09bd27a7b660830de45bb
From 8883c4f5a29be18e9ea09bd27a7b660830de45bb Mon Sep 17 00:00:00 2001
From: Thien-Thi Nguyen <ttn@gnu.org>
Date: Fri, 23 Oct 2020 09:23:49 -0400
Subject: [v] Don't test signal handling if stdin not ok.
<https://mail.gnu.org/archive/html/bug-rcs/2020-10/msg00014.html>
* tests/t632: If stdin is not open and connected to
a tty, skip the signal handling portion of the test.
---
tests/ChangeLog | 9 +++++++++
tests/t632 | 9 +++++++++
2 files changed, 18 insertions(+)
diff --git a/tests/ChangeLog b/tests/ChangeLog
index c3715c0..0565058 100644
--- a/tests/ChangeLog
+++ b/tests/ChangeLog
@@ -1,3 +1,12 @@
+2020-10-23 Thien-Thi Nguyen <ttn@gnu.org>
+
+ [v] Don't test signal handling if stdin not ok.
+
+ <https://mail.gnu.org/archive/html/bug-rcs/2020-10/msg00014.html>
+
+ * t632: If stdin is not open and connected to
+ a tty, skip the signal handling portion of the test.
+
2020-10-20 Thien-Thi Nguyen <ttn@gnu.org>
Release: 5.10.0
diff --git a/tests/t632 b/tests/t632
index df6acc9..677ec8c 100644
--- a/tests/t632
+++ b/tests/t632
@@ -40,6 +40,15 @@ echo | co -l -I $w \
# (This is skipped if GNU coreutils timeout(1) is not available.)
##
+# <https://mail.gnu.org/archive/html/bug-rcs/2020-10/msg00014.html>
+# The timeout test needs co(1) to block on input.
+# If stdin is not open and connected to a tty, skip out.
+if test -t 0 ; then
+ echo STDIN OK
+else
+ exit 0
+fi
+
# TODO: Don't be lame! Pick one:
# (a) Mimic timeout(1) w/ sh commands.
# (b) Incorporate heart of timeout(1) into ./btdt and use that.
--
cgit v1.2.1