guix/gnu/packages/patches/mingw-w64-reproducible-gendef.patch
Carl Dong 4719b71572
gnu: mingw: Add mingw-w64 reproducibility patches.
These patches were originally found at the debian mingw-w64 team's
mingw-w64 repo, and should improve the reproducibility of our mingw-w64
toolchain.

* gnu/packages/patches/mingw-w64-dlltool-temp-prefix.patch: New file.
* gnu/packages/patches/mingw-w64-reproducible-gendef.patch: New file.
* gnu/local.mk (dist_patch_DATA): Update accordingly.
* gnu/packages/mingw.scm (make-mingw-w64): Apply patches.
2020-04-04 16:23:07 -04:00

24 lines
914 B
Diff

This following patch was originally found at the debian mingw-w64 team's
mingw-w64 repo located here:
https://salsa.debian.org/mingw-w64-team/mingw-w64.git
Invoke the following in the aforementioned repo to see the original patch:
$ git show 4974e2c:debian/patches/reproducible-gendef.patch
Description: Drop __DATE__ from gendef
Author: Stephen Kitt <skitt@debian.org>
This allows gendef to be built reproducibly.
--- a/mingw-w64-tools/gendef/src/gendef.c
+++ b/mingw-w64-tools/gendef/src/gendef.c
@@ -196,7 +196,6 @@
" By default, the output files are named after their DLL counterparts\n"
" gendef MYDLL.DLL Produces MYDLL.def\n"
" gendef - MYDLL.DLL Prints the exports to stdout\n");
- fprintf (stderr, "\nBuilt on %s\n", __DATE__);
fprintf (stderr, "\nReport bugs to <mingw-w64-public@lists.sourceforge.net>\n");
exit (0);
}