guix/gnu/packages/patches/binutils-mingw-w64-deterministic.patch
Ludovic Courtès 523280e099
gnu: binutils: Shorten file names of MinGW patches.
This ensures we stay below the POSIX tar file name length limit.

* gnu/packages/patches/binutils-mingw-w64-reproducible-import-libraries.patch:
Rename to...
* gnu/packages/patches/binutils-mingw-w64-deterministic.patch: ... this.
* gnu/packages/patches/binutils-mingw-w64-specify-timestamp.patch:
Rename to...
* gnu/packages/patches/binutils-mingw-w64-timestamp.patch: ... this.
* gnu/local.mk (dist_patch_DATA): Adjust accordingly.
* gnu/packages/cross-base.scm (cross-binutils): Likewise.
2020-04-10 16:02:51 +02:00

23 lines
741 B
Diff

This following patch was originally found at the debian mingw-w64 team's
binutils repo located here:
https://salsa.debian.org/mingw-w64-team/binutils-mingw-w64.git
Invoke the following in the aforementioned repo to see the original patch:
$ git show da63f6b:debian/patches/reproducible-import-libraries.patch
Description: Make DLL import libraries reproducible
Author: Benjamin Moody <benjamin.moody@gmail.com>
Bug-Debian: https://bugs.debian.org/915055
--- a/ld/pe-dll.c
+++ b/ld/pe-dll.c
@@ -2844,6 +2844,7 @@
bfd_set_format (outarch, bfd_archive);
outarch->has_armap = 1;
+ outarch->flags |= BFD_DETERMINISTIC_OUTPUT;
/* Work out a reasonable size of things to put onto one line. */
ar_head = make_head (outarch);