aa6e6fb2e9
* gnu/packages/image-viewers.scm (ytfzf): New variable. Co-authored-by: jgart <jgart@dismail.de>
44 lines
1.3 KiB
Diff
44 lines
1.3 KiB
Diff
From ceb6836cd31653267506957cd0ccf78046404d3b Mon Sep 17 00:00:00 2001
|
|
From: Raghav Gururajan <rg@raghavgururajan.name>
|
|
Date: Mon, 5 Jul 2021 06:47:38 -0400
|
|
Subject: [PATCH 2/2] Disable updates within the application.
|
|
|
|
Patch the code responsible for self-updating the application.
|
|
|
|
Co-authored-by: jgart <jgart@dismail.de>
|
|
---
|
|
ytfzf | 18 ++----------------
|
|
1 file changed, 2 insertions(+), 16 deletions(-)
|
|
|
|
diff --git a/ytfzf b/ytfzf
|
|
index f0f2e16..2d1bb2e 100755
|
|
--- a/ytfzf
|
|
+++ b/ytfzf
|
|
@@ -1260,22 +1260,8 @@ EOF
|
|
}
|
|
|
|
update_ytfzf () {
|
|
- branch="$1"
|
|
- updatefile="/tmp/ytfzf-update"
|
|
- curl -L "https://raw.githubusercontent.com/pystardust/ytfzf/$branch/ytfzf" -o "$updatefile"
|
|
-
|
|
- if sed -n '1p' < "$updatefile" | grep -q '#!/bin/sh'; then
|
|
- chmod 755 "$updatefile"
|
|
- [ "$(uname)" = "Darwin" ] && prefix="/usr/local/bin" || prefix="/usr/bin"
|
|
- function_exists "sudo" && doasroot="sudo" || doasroot="doas"
|
|
- $doasroot cp "$updatefile" "$prefix/ytfzf"
|
|
- unset prefix doasroot
|
|
- else
|
|
- printf "%bFailed to update ytfzf. Try again later.%b" "$c_red" "$c_reset"
|
|
- fi
|
|
-
|
|
- rm "$updatefile"
|
|
- exit 0
|
|
+ printf "%bUpdates have to be installed with Guix.%b\n" "$c_red" "$c_reset"
|
|
+ exit 1
|
|
}
|
|
|
|
#gives a value to sort by (this will give the unix time the video was uploaded)
|
|
--
|
|
2.32.0
|
|
|