guix/gnu/packages/patches/vtk-7-python-compat.patch

17 lines
673 B
Diff

Author: Gert Wollny <gewo@debian.org>
Description: Work around compile bug with python 3.7.1
Debian-Bug: https://bugs.debian.org/914347
diff --git a/Wrapping/PythonCore/vtkPythonArgs.cxx b/Wrapping/PythonCore/vtkPythonArgs.cxx
index 1b1e4b9..682f8b8 100644
--- a/Wrapping/PythonCore/vtkPythonArgs.cxx
+++ b/Wrapping/PythonCore/vtkPythonArgs.cxx
@@ -102,7 +102,7 @@ bool vtkPythonGetStringValue(PyObject *o, T *&a, const char *exctext)
else if (PyUnicode_Check(o))
{
#if PY_VERSION_HEX >= 0x03030000
- a = PyUnicode_AsUTF8(o);
+ a = const_cast<char*>(PyUnicode_AsUTF8(o));
return true;
#else
PyObject *s = _PyUnicode_AsDefaultEncodedString(o, NULL);