guix/gnu/packages/patches/aws-c-auth-install-private-...

20 lines
948 B
Diff

aws-sdk-cpp depends on the private headers from aws-c-auth. This dependency was
added to aws-sdk-cpp in commit 23cca02c2df on 2021-06-04.
The following error is generated when building aws-sdk-cpp when the private
aws-c-auth headers are not installed:
/tmp/guix-build-aws-sdk-cpp-1.9.121.drv-0/aws-sdk-cpp-1.9.121-checkout/aws-cpp-sdk-core-tests/aws/auth/AWSAuthSignerTest.cpp:17:10: fatal error: aws/auth/private/aws_signing.h: No such file or directory
#include <aws/auth/private/aws_signing.h>
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -110,6 +114,7 @@ target_link_libraries(${PROJECT_NAME} PUBLIC ${DEP_AWS_LIBS} ${PLATFORM_LIBS})
aws_prepare_shared_lib_exports(${PROJECT_NAME})
install(FILES ${AWS_AUTH_ROOT_HEADERS} DESTINATION "include/aws/auth" COMPONENT Development)
+install(FILES ${AWS_AUTH_PRIVATE_HEADERS} DESTINATION "include/aws/auth/private" COMPONENT Development)
if (BUILD_SHARED_LIBS)
set (TARGET_DIR "shared")