guix/gnu/packages/patches/agg-2.5-gcc8.patch

15 lines
915 B
Diff

Taken from: https://gitweb.gentoo.org/repo/gentoo.git/tree/x11-libs/agg/files/agg-2.5-gcc8.patch.
diff -uprN agg-2.5/include/agg_renderer_outline_aa.h agg-2.5-fixed/include/agg_renderer_outline_aa.h
--- agg-2.5/include/agg_renderer_outline_aa.h 2018-08-25 02:02:52.507254241 +0800
+++ agg-2.5-fixed/include/agg_renderer_outline_aa.h 2018-08-25 02:04:15.291175316 +0800
@@ -1375,7 +1375,7 @@ namespace agg
//---------------------------------------------------------------------
void profile(const line_profile_aa& prof) { m_profile = &prof; }
const line_profile_aa& profile() const { return *m_profile; }
- line_profile_aa& profile() { return *m_profile; }
+ const line_profile_aa& profile() { return *m_profile; }
//---------------------------------------------------------------------
int subpixel_width() const { return m_profile->subpixel_width(); }