gnu: python-jedi: Update to 0.17.0.

* gnu/packages/python-xyz.scm (python-jedi): Update to 0.17.0.
[source](patches): Remove.
* gnu/packages/patches/python-jedi-deleted-variables.patch: Delete file.
* gnu/local.mk (dist_patch_DATA): Adjust accordingly.
This commit is contained in:
Marius Bakke 2020-04-15 13:23:40 +02:00
parent 2708ae3d69
commit ff2bf8a223
No known key found for this signature in database
GPG key ID: A2A06DF2A33A54FA
3 changed files with 2 additions and 42 deletions

View file

@ -1364,7 +1364,6 @@ dist_patch_DATA = \
%D%/packages/patches/python-pep8-stdlib-tokenize-compat.patch \
%D%/packages/patches/python-pyfakefs-remove-bad-test.patch \
%D%/packages/patches/python-flint-includes.patch \
%D%/packages/patches/python-jedi-deleted-variables.patch \
%D%/packages/patches/python-libxml2-utf8.patch \
%D%/packages/patches/python-mox3-python3.6-compat.patch \
%D%/packages/patches/python-testtools.patch \

View file

@ -1,38 +0,0 @@
Fix test failure in some environments, including Guix.
Taken from upstream:
https://github.com/davidhalter/jedi/commit/bec87f7ff82b0731713c6520a14c213341b4cecf
diff --git a/test/completion/basic.py b/test/completion/basic.py
index b40068179..3ff919ca6 100644
--- a/test/completion/basic.py
+++ b/test/completion/basic.py
@@ -209,11 +209,11 @@ def global_as_import():
deleted_var = 3
del deleted_var
-#? int()
+#?
deleted_var
-#? ['deleted_var']
+#? []
deleted_var
-#! ['deleted_var = 3']
+#! []
deleted_var
# -----------------
diff --git a/test/test_api/test_full_name.py b/test/test_api/test_full_name.py
index 4fdb861b0..6858b6ca8 100644
--- a/test/test_api/test_full_name.py
+++ b/test/test_api/test_full_name.py
@@ -112,7 +112,8 @@ def test_os_path(Script):
def test_os_issues(Script):
"""Issue #873"""
- assert [c.name for c in Script('import os\nos.nt''').complete()] == ['nt']
+ # nt is not found, because it's deleted
+ assert [c.name for c in Script('import os\nos.nt''').complete()] == []
def test_param_name(Script):

View file

@ -11912,15 +11912,14 @@ (define-public python2-prompt-toolkit-1
(define-public python-jedi
(package
(name "python-jedi")
(version "0.16.0")
(version "0.17.0")
(source
(origin
(method url-fetch)
(uri (pypi-uri "jedi" version))
(patches (search-patches "python-jedi-deleted-variables.patch"))
(sha256
(base32
"1mb5kmrk9bkc3kwzx02j62cdan1jqd92q1z7h7wi9d30jg5p3j6m"))))
"0c1h9x3a9klvk2g288wl328x8xgzw7136k6vs9hkd56b85vcjh6z"))))
(build-system python-build-system)
(arguments
`(#:phases