gnu: pitivi: Update to 2022.06.0.

* gnu/packages/patches/pitivi-fix-build-with-meson-0.60.patch: Delete file.
* gnu/local.mk (dist_patch_DATA): De-register it.
* gnu/packages/video.scm (pitivi): Update to 2022.06.0.
[version]: Do not prefix with previous semver version.
[inputs]{gst-plugins/selection}: Add comment about cvtracker.
{python-librosa}: New input.
This commit is contained in:
Maxim Cournoyer 2022-07-07 11:42:38 -04:00
parent 47f0b3ad14
commit fa4a9016be
No known key found for this signature in database
GPG key ID: 1260E46482E63562
3 changed files with 65 additions and 113 deletions

View file

@ -1591,7 +1591,6 @@ dist_patch_DATA = \
%D%/packages/patches/password-store-tree-compat.patch \
%D%/packages/patches/pciutils-hurd-configure.patch \
%D%/packages/patches/pciutils-hurd-fix.patch \
%D%/packages/patches/pitivi-fix-build-with-meson-0.60.patch \
%D%/packages/patches/pjproject-install-libpjsua2.patch \
%D%/packages/patches/plasma-framework-fix-KF5PlasmaMacros.cmake.patch \
%D%/packages/patches/ppsspp-disable-upgrade-and-gold.patch \

View file

@ -1,46 +0,0 @@
From b54da52289f9578d7021f466d731cfd48330e5fe Mon Sep 17 00:00:00 2001
From: Leo Famulari <leo@famulari.name>
Date: Thu, 25 Nov 2021 18:56:44 -0500
Subject: [PATCH] Fix build with Meson 0.60.
https://gitlab.gnome.org/GNOME/pitivi/-/issues/2593
* data/meson.build: Adjust to changes in Meson 0.60.
---
data/meson.build | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)
diff --git a/data/meson.build b/data/meson.build
index 2ea82cf..60d2316 100644
--- a/data/meson.build
+++ b/data/meson.build
@@ -6,7 +6,7 @@ install_subdir('audiopresets', install_dir: pkgdatadir)
install_subdir('videopresets', install_dir: pkgdatadir)
install_subdir('gstpresets', install_dir: pkgdatadir)
-desktop_file = i18n.merge_file('org.pitivi.Pitivi.desktop',
+desktop_file = i18n.merge_file(
type: 'desktop',
output : 'org.pitivi.Pitivi.desktop',
input : 'org.pitivi.Pitivi.desktop.in',
@@ -25,7 +25,7 @@ if desktop_file_validate.found()
)
endif
-appdata_file = i18n.merge_file('org.pitivi.Pitivi.appdata.xml',
+appdata_file = i18n.merge_file(
type: 'xml',
output : 'org.pitivi.Pitivi.appdata.xml',
input : 'org.pitivi.Pitivi.appdata.xml.in',
@@ -43,7 +43,7 @@ if appstream_util.found()
)
endif
-i18n.merge_file('org.pitivi.Pitivi-mime.xml',
+i18n.merge_file(
output : 'org.pitivi.Pitivi-mime.xml',
input : 'org.pitivi.Pitivi-mime.xml.in',
po_dir: podir,
--
2.33.1

View file

@ -4323,22 +4323,18 @@ (define-public aegisub
; src/MatroskaParser.(c|h) is under bsd-3 with permission from the author
(define-public pitivi
;; Pitivi switched to a non-semantic versioning scheme close before 1.0
(let ((latest-semver "0.999.0")
(%version "2021.05.0"))
(package
(name "pitivi")
(version (string-append latest-semver "-" %version))
(version "2022.06.0")
(source
(origin
(method git-fetch)
(uri (git-reference
(url "https://gitlab.gnome.org/GNOME/pitivi.git")
(commit %version)))
(commit version)))
(file-name (git-file-name name version))
(patches (search-patches "pitivi-fix-build-with-meson-0.60.patch"))
(sha256
(base32 "08x2fs2bak1fbmkvjijgx1dsawispv91bpv5j5gkqbv5dfgf7wah"))))
(base32 "1wgfi8srblqzd2y6528cyvn56rbdxpwlq0wmwqhabshdk28zyx8d"))))
(build-system meson-build-system)
(native-inputs
(list gettext-minimal
@ -4352,6 +4348,8 @@ (define-public pitivi
gstreamer
gst-plugins-base
gst-plugins-good
;; TODO: Add the 'cvtracker' plugin after our gstreamer packages
;; has been upgraded to version 1.20.
(gst-plugins/selection gst-plugins-bad #:plugins
'("debugutils" "transcode")
#:configure-flags
@ -4364,6 +4362,7 @@ (define-public pitivi
pango
python
python-gst
python-librosa
python-numpy
python-matplotlib
python-pycairo
@ -4390,7 +4389,7 @@ (define-public pitivi
(description "Pitivi is a video editor built upon the GStreamer Editing
Services. It aims to be an intuitive and flexible application that can appeal
to newbies and professionals alike.")
(license license:lgpl2.1+))))
(license license:lgpl2.1+)))
(define-public gavl
(package