netsurf: Upgrade to 3.8.

* gnu/packages/patches/netsurf-message-timestamp.patch: New patch.
* gnu/packages/patches/netsurf-system-utf8proc.patch: Adjust to new source.
* gnu/packages/web.scm (netsurf): Upgrade to 3.8.
[source]: Add the new patch.
This commit is contained in:
Eric Bavier 2018-08-29 14:12:58 -05:00 committed by Eric Bavier
parent c558113fb9
commit f9e140a243
No known key found for this signature in database
GPG key ID: FD73CAC719D32566
3 changed files with 28 additions and 15 deletions

View file

@ -0,0 +1,11 @@
--- netsurf-3.8/utils/split-messages.pl.orig 1969-12-31 18:00:00.000000000 -0600
+++ netsurf-3.8/utils/split-messages.pl 2018-08-30 00:18:58.158367530 -0500
@@ -238,7 +238,7 @@
if( $opt{gzip} )
{
- $ofh = new IO::Compress::Gzip( $ofh, AutoClose => 1, -Level => 9 );
+ $ofh = new IO::Compress::Gzip( $ofh, AutoClose => 1, -Level => 9, Time => 0 );
}
return $ofh;

View file

@ -17,23 +17,23 @@ Work around upstream's lack of a pkg-config file and update API.
# Optional libraries with pkgconfig
--- netsurf-3.6/utils/idna.c
+++ netsurf-3.6/utils/idna.c
@@ -26,7 +26,7 @@
#include <stdint.h>
--- netsurf-3.8/utils/idna.c
+++ netsurf-3.8/utils/idna.c
@@ -27,7 +27,7 @@
#include <stdlib.h>
#include <string.h>
#include <sys/types.h>
-#include <libutf8proc/utf8proc.h>
+#include <utf8proc.h>
#include "utils/errors.h"
#include "utils/idna.h"
--- netsurf-3.7/test/Makefile 2017-10-15 08:39:24.000000000 -0500
+++ netsurf-3.7/test/Makefile 2017-11-05 11:14:46.219013218 -0600
@@ -139,14 +139,14 @@
-D_XOPEN_SOURCE=600 \
#include "netsurf/inttypes.h"
--- netsurf-3.8/test/Makefile
+++ netsurf-3.8/test/Makefile
@@ -142,14 +142,15 @@
-Itest -Iinclude -Icontent/handlers -Ifrontends -I. -I.. \
-Dnsgtk \
$(SAN_FLAGS) \
- $(shell pkg-config --cflags libcurl libparserutils libwapcaplet libdom libnsutils libutf8proc) \
+ $(shell pkg-config --cflags libcurl libparserutils libwapcaplet libdom libnsutils) \
$(LIB_CFLAGS)
@ -43,7 +43,8 @@ Work around upstream's lack of a pkg-config file and update API.
TESTLDFLAGS := -L$(TESTROOT) \
- $(shell pkg-config --libs libcurl libparserutils libwapcaplet libdom libnsutils libutf8proc) -lz \
+ $(shell pkg-config --libs libcurl libparserutils libwapcaplet libdom libnsutils) -lz -lutf8proc \
+ $(shell pkg-config --libs libcurl libparserutils libwapcaplet libdom libnsutils) \
+ $(LDFLAGS) \
$(SAN_FLAGS) \
$(LIB_LDFLAGS)\
$(COV_LDFLAGS)

View file

@ -4694,7 +4694,7 @@ (define-public nsgenbind
(define-public netsurf
(package
(name "netsurf")
(version "3.7")
(version "3.8")
(source
(origin
(method url-fetch)
@ -4702,10 +4702,11 @@ (define-public netsurf
"releases/source/netsurf-" version "-src.tar.gz"))
(sha256
(base32
"05kynfzzwd4fc03vbqdjpghh5xnk2yrh43w7vikak89vla30mhpg"))
"0hjm1h4m1i913y4mhkl7yqdifn8k70fwi58zdh6faypawzryc3m0"))
(patches (search-patches "netsurf-system-utf8proc.patch"
"netsurf-y2038-tests.patch"
"netsurf-longer-test-timeout.patch"))))
"netsurf-longer-test-timeout.patch"
"netsurf-message-timestamp.patch"))))
(build-system glib-or-gtk-build-system)
(native-inputs
`(("netsurf-buildsystem" ,netsurf-buildsystem)